Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 


Forum Übersicht | Suche | Registrieren | Login | Online? | Mitglieder | Landkarte | Globale Map | FAQ
Sie können sich hier anmelden
Dieses Thema hat 18 Antworten
und wurde 1.210 mal aufgerufen
Bei Antworten informieren
Raiders-PG-Forum » Equipment & Patches » Equipment & Patches » Probleme bei Neuinstallation unter XP Sortierung: Alte Beiträge zuerst  
wenz71

29.06.2008 23:00
Probleme bei Neuinstallation unter XP Thread geschlossen
Hallo erst einmal,



vorab ich bin neu hier, deshalb sorry falls ich irgendwelche Regeln übersehen haben sollte.

Also: ich spiele gerne panzer General 3d.



Leider musste mien Rechner zur Repaartur und als ich danach P 3 d neu installieren wollte, liess sich das Spiel nicht starten.



Das "Intro" ging ganz normal, aber als ich eine Kapagne auswählen wollte,

blieb die Maus hängen, nichts rührte sich und das Speil stürte ab.



Folgende Fehlermeldung erscheint:



AppName: panzer3d.exe AppVer: 0.0.0.0 ModName: panzer3d.exe

ModVer: 0.0.0.0 Offset: 000111d1



Dass Umstellen auf Kompatibiltätsmodus hilft nicht.



Falls es hilft, mein System



Windows XP

NVIDIA Geforce 6700XL



Hat jemand eine Idee, was ich machen kann ?



Danke
Rayydar
Generalspammarschall
Beiträge: 11.396


29.06.2008 23:28
Probleme bei Neuinsatllation unter XP Thread geschlossen
Hardwarebeschleunigung?
PG3 kommt mit den neuen DirectX-Versionen nicht mehr klar.
Grafik-Beschleunigung um 3 Striche nach links runterregeln:
Systemsteuerung -> Anzeige -> Einstellungen -> Erweitert -> Problembehandlung.

Das Fenster am besten offen lassen, denn nach PG3 musst du das evtl. für andere Games wieder rückgängig machen.
Jaelor
Schreibstubenhengst
Beiträge: 52

30.06.2008 00:22
Probleme bei Neuinsatllation unter XP Thread geschlossen
den Tip sollte man evtl. schon Sticky machen da immer wieder danach gefragt wird.
Gerd
Oberst d. Fernschreiber
Beiträge: 2.699


30.06.2008 23:17
Probleme bei Neuinsatllation unter XP Thread geschlossen
Also am System selbst und der Grafikkarte sollte es eigentlich nicht liegen.
Welchen Treiber benutzt du für die Karte?
Die neueste DirectX Variante wird meist für viele andere Spiele genutzt.
Hab auch XP Sp3 und Nvidia 6800GT mit Treiber 77.72. Der hat bisher gute Dienste geleistet was Leistung und Stabilität angeht.
Die Hardware Beschleunigung ist bei meinem System auf max., problemlos.

Fehler können immer wieder mal auftreten, sind meist aber durch Anwender hervorgerufen oder durch eine Neuinstallation zu beheben.
Rayydar
Generalspammarschall
Beiträge: 11.396


01.07.2008 10:43
Probleme bei Neuinsatllation unter XP Thread geschlossen

Quote:
den Tip sollte man evtl. schon Sticky machen da immer wieder danach gefragt wird.

Ja, mach doch! Prio 9, und schon isses immer ganz oben.
wenz71

01.07.2008 18:48
Probleme bei Neuinsatllation unter XP Thread geschlossen
Hallo,

erst einmal danke; zwei Stufen nach Links auf der
Grafikkarten"beschleunigung" und es ging wieder.

Sorry, aber jetzt habe ich noch eine Sache:

Habe mir einige "Tools" von dieser Seite heruntergeladen.

Jetzt könnte ich spielen, aber

1) mir werden bsw. unter Panzer auch Schiffe zum Kauf angeboten

2) einige Einheiten, die ich kaufen könnte haben keine Bezeichnung,ich sehe nur das Bild ohne Text (also bsw. BF110 e usw.)

Was kann ich machen ?

Danke für eure Tipps :-)
wenz71

01.07.2008 18:49
Probleme bei Neuinsatllation unter XP Thread geschlossen

Hallo,

erst einmal danke; zwei Stufen nach Links auf der
Grafikkarten"beschleunigung" und es ging wieder.

Sorry, aber jetzt habe ich noch eine Sache:

Habe mir einige "Tools" von dieser Seite heruntergeladen.

Jetzt könnte ich spielen, aber

1) mir werden bsw. unter Panzer auch Schiffe zum Kauf angeboten

2) einige Einheiten, die ich kaufen könnte haben keine Bezeichnung,ich sehe nur das Bild ohne Text (also bsw. BF110 e usw.)

Was kann ich machen ?

Danke für eure Tipps :-)
Rubberduck
Stabsschreiber
Beiträge: 912


01.07.2008 21:11
Probleme bei Neuinsatllation unter XP Thread geschlossen
Welches Equipment File nutzt Du? Hoffentlich RSF2.70
Lies Dir die Installationsanleitung genau durch. Dann funzt es auch mit dem Spiel
Galland
Verbalkanonier
Beiträge: 589


03.07.2008 18:11
Probleme bei Neuinsatllation unter XP Thread geschlossen
Wie die Gummiente es schon ausführte : Lese in Ruhe die Anleitung - es hilft ungemein !!! Ansonsten durchforste mal unser Forum, fast alle Probleme und Katastrophen sind wohl schon irgendwo hier behandelt worden.

Und wenn dann dein Schädel brummt und du nur noch Bahnhof verstehst - frag einfach nach, wir werden dir schon helfen - irgendwie
pzueco

19.07.2008 05:05
Probleme bei Neuinsatllation unter XP Thread geschlossen
hi, hab das spiel gerade auch mal wieder ausgegraben

wollte mit nem freund ne partie im netzwerk zocken, hatte dann auch das problem das es abstürzt nach dem intro, lässt sich die maus lurz bewegegen
und dann kommt windows mit problem bericht senden.
hab dann die tips hier mit der hardware beschleunigung gelesen. gut
bei meinem direct x gab es nur dxdiag aber keinen regler zum verschieben.
hab dann den obersten button für die hardware beschhleunigung ausgemacht, welcher die anderne beiden mit agp beschleunigung und den 3. weiss jetzt net mehr was gleich mit deaktiviert.

danach lief das spiel auch, nur der statusbercht ist etwas rucklig und langsam.

so jetzt nachn paar runden ist das spiel aber wieder gecrasht mit der gleichen "problem bericht windows" meldung.

gibs noch mehr tips und hilfen?=

system: athlon 64 irgendwas
nv gf 6600 mit recht aktuellem treiber
dx9c müsste das sein.

sorry weiss über mein system gerade net so bescheid
und entschuldigt die rechtschreib fehler ist schon recht spät
überhaupot n wunder das ich mein login hier noch kenne ;() und mein account noch existierttiert


achja pg mit dem neusten rsf teil soweit ich das überblicke.
wie auch vorher erwänt das letzte mal lief es an dem rechner noch alles perfekt. bis auf die schnelle scroll geschwindigkeit
weiss auch net was ich da geändert habe höchstens graka treiber.

naja beim schreiben fällt mir gerade ein das es bei system steuerung noch irgendwo ne hardware beschleunigng gab mit regler sogar,. meint ihr die?


wöre nett wenn noch npaar tipps zusammne kommen

mfg pzueco


naja bis das dann wieder läuft spieln wir erstmal ne runde master of orion 2 im netz

hf und good morning
Rayydar
Generalspammarschall
Beiträge: 11.396


19.07.2008 13:18
Probleme bei Neuinsatllation unter XP Thread geschlossen

Quote:
naja beim schreiben fällt mir gerade ein das es bei system steuerung noch irgendwo ne hardware beschleunigng gab mit regler sogar,. meint ihr die?

Ja!
Ahnungsloser

23.07.2008 00:30
Probleme bei Neuinsatllation unter XP Thread geschlossen
Hi,

ich habe leider auch ein ähnliches problem.

Habe das Spiel ausgegraben und wollte etwas zocken, doch regelmäßig stürzt es ab und in allen möglichen Unterordnern nistet sich ein
"Konvertierungsfehler" ein. Was istdas und was kann ich dagegen tun ?

Meist steht nix drinne, manchmal aber auch :


DTR12L.DEU :
„ (ascii werte 132) ist konvertiert zu leerzeichen.
GE71L.DEU :
… (ascii werte 133) ist konvertiert zu leerzeichen.
GE73BV.DEU :
„ (ascii werte 132) ist konvertiert zu leerzeichen.
GE74V.DEU :
„ (ascii werte 132) ist konvertiert zu leerzeichen.
UK37BV.DEU :
„ (ascii werte 132) ist konvertiert zu leerzeichen.

Ich versteh leider nur Bahnhof. Hat jemand eine Idee ? Nutze Widnows xp, das Spiel starte normal und stürzt ab, bzw. Kampagnen werden nicht
bendet.

Ach ja: ich nutze XP, falls das etwas zu bdeuten hat.

P. S.: Gibt es eigentlich einen "idiotensicheren" Leitfaden wie (und in welcher Reihenfolge) ich die ganzen Features installieren soll. Vielleicht habe ich etwas falsch installiert.

Danke

Andreas


Clu
Oberst d. Fernschreiber
Beiträge: 3.919


23.07.2008 09:21
Probleme bei Neuinsatllation unter XP Thread geschlossen
Hi und willkommen!

Was das Computerkauderwelsch bedeutet weiß ich nicht.
Aber: Eine Installationsanleitung gibts auf der Hauptseite. Folge einfach den Anweisungen dort.

Clu
Rayydar
Generalspammarschall
Beiträge: 11.396


23.07.2008 13:58
Probleme bei Neuinsatllation unter XP Thread geschlossen
Wenn du irgendwelche Mods, also nicht nur die dt. Originalversion von CD benutzt, darfst du keine DEU-Files verwenden!
Zieh dir am besten das UK-Patch aus unserem Download; da sind alle benötigten TXT- (statt DEU-) Dateien drin.
Major Heinz
Literaturmajor
Beiträge: 1.187

11.02.2009 02:44
Probleme bei Neuinsatllation unter XP Thread geschlossen
Für alle die wie Ahnungsloser die Datei "Konvertierungsfehler.txt" entdecken sollten, das gehört wohl so. Die Datei ist so im UK Patch Download drin.
waitsnake
Nachschubgefreiter
Beiträge: 17


15.05.2009 02:21
RE: Probleme bei Neuinsatllation unter XP Thread geschlossen

Zitat von wenz71

Das "Intro" ging ganz normal, aber als ich eine Kapagne auswählen wollte,
blieb die Maus hängen, nichts rührte sich und das Speil stürte ab.

Folgende Fehlermeldung erscheint:
AppName: panzer3d.exe AppVer: 0.0.0.0 ModName: panzer3d.exe
ModVer: 0.0.0.0 Offset: 000111d1
...
Hat jemand eine Idee, was ich machen kann ?


Hallo,
ich habe mir den Fehler mal mit einem Debugger angesehen. Das Problem mit dem Absturz unter XP liegt nicht wie bisher vermutet an einer Inkompatibilität mit DirectX sondern an PG3D selbst. Das Spiel enthält einen Speicherfehler beim kopieren einer Grafik von einem Teil des Videospeichers in einen anderen Teil. Win95 und Win98 nehmen es mit dem Speicherschutz im Grafikspeicher nicht ganz so genau wie XP und daher hat den Fehler damals niemand bemerkt.

Wenn man das Spiel ohne Hardwarebeschleunigung spielt, befinden sich die Grafiken dagegen nicht direkt in den Videospeicher der Grafikkarte, sondern werden erstmal in normalen dem Anwendungsspeicher von DirectDraw verwaltet, bevor sie dargestellt werden. Da dieses Speichersegment recht groß ist, gibt es im Softwaremodus ebenfalls keine Probleme. Wenn man mal davon absieht, dass die Maus im Softwaremodus viel zu schnell scrollt, da hier das VertikalRetrace nicht emuliert wird. Letzteres Problem war für mich unzumutbar.

Details zum Fehler:
Das SurfaceObject des bunten Mauszeigers hat eine Größe von 90x70=6300 Byte. In dem Moment, wenn sich der Mauszeiger über einem Menüknopf befindet soll ein Text dargestellt werden, welcher den Menüknopf näher erläutert. Dabei wird aufgrund eines Fehlers der Inhalt eines anderen SurfaceObjects in das SurfaceObject des Mauszeigers kopiert. Da das andere Surface mit 200x60=12000 Byte viel größer ist, kommt es zu einer Speicherschutzverletzung und das Spiel wird von XP beendet.

Was kann man machen?
1.) Das Programm (PG2UK220.EXE) mit einem Hexeditor (z.B. HxD) öffnen.
2.) Die Adresse 00084289h suchen, welche mit einer 55h gefüllt ist
3.) Die 55 durch C3 ersetzen
4.) Das Programm unter neuen Namen im selben Ordner speichern, z.B als PG2UK221.EXE
5.) PG2UK221.EXE ganz normal starten (also mit Hardwarebeschleunigung)

Dieser Patch funktioniert nur bei dem UK-Patch 2.20. Für andere PG3D-Versionen müsste man die richtige Adresse erst noch raussuchen.

Der Patch ist auch noch nicht optimal, da ich einfach die fehlerhafte Routine ausgeschaltet habe, welche die Menühilfetexte zeichnet. Also nicht wundern, wenn diese Texte plötzlich fehlen. Mich selbst stören die fehlenden Texte nicht so, da ich die Bedeutung der Knöpfe eh aus dem FF kenne. Dafür genieße ich jetzt beim spielen wider, dass angenehm langsame scrollen mit der Maus über die Karte.

Ciao Waitsnake

Rayydar
Generalspammarschall
Beiträge: 11.396


15.05.2009 14:38
RE: Probleme bei Neuinstallation unter XP Thread geschlossen

Hey Waitsnake,

das nenne ich mal einen gelungenen Forumseinstieg!
Du kennst dich ja heftig aus. Wenn das klappt, wird dir die PG3-Welt zu Füßen liegen!
Werde es jetzt mal testen.


Lufthoheit ist nicht alles. Aber ohne Lufthoheit ist alles nichts!

waitsnake
Nachschubgefreiter
Beiträge: 17


16.05.2009 00:12
RE: Probleme bei Neuinstallation unter XP Thread geschlossen

Prima, dann kannst du ja für mich Beta-Tester spielen.
Gib mir bitte ein Feedback, ob es bei dir läuft. Ich habe es bisher nur mit meinen XP SP3 mit Nvidia-Graka getestet.

Aber wenn du die selbe PG2UK220.EXE hast, wie ich hier (Größe 854.528 Bytes), wird es hoffentlich funktionieren.

Falls du bei der beschrieben Adresse keine 55 finden solltest, hast du eine anderes Executable.
Dann könntest du immer noch nach der Bytesequenz 558bec83ec78535657c745906c000000
suchen, wobei die erste 55 durch das C3 (Assembler für "retn") ersetzt werden muss.

Bei PG3D v102 (Größe 853.504 Bytes) beginnt die Sequenz z.B. bei der Adresse 00057319h.

Raiders-PG-Forum » Equipment & Patches » Equipment & Patches » Probleme bei Neuinstallation unter XP
   

  PBEM-Liga für PG3D und viele weitere Spiele: »Panzerliga.de« » Internationales PG-Forum: »JP's Panzers« (engl.)  

Xobor Ein Kostenloses Forum von Xobor.de
Einfach ein Forum erstellen